Main Phone Number Currently Not Available
Incident Report for Unbounce
Resolved
We're now confident that our phones are working as per normal. Apologies for any inconvenience.
Posted 4 months ago. Apr 10, 2017 - 13:34 PDT
Monitoring
Our phone system should now be operating normally, but we are monitoring to ensure the issue doesn't recur.
Posted 4 months ago. Apr 10, 2017 - 12:32 PDT
Update
We are currently experiencing issues with our third-party phone support client, and Unbounce phone support is currently unavailable. For support, please get in touch via the alternate number 1-855-435-5151 or support@unbounce.com.
Posted 4 months ago. Apr 10, 2017 - 09:49 PDT
Investigating
We are currently experiencing issues with our third-party phone support client, and Unbounce phone support is currently unavailable. For support, please get in touch at support@unbounce.com.
Posted 4 months ago. Apr 10, 2017 - 09:25 PDT